Cambiar idioma a escritorio xfce

Todo lo relacionado con los entornos de escritorio, todas las aplicaciones, tanto KDE, Gnome y otros. Si tenes un problema con un programa, muy probablemente este sea el foro indicado.

Cambiar idioma a escritorio xfce

Notapor ediaz » 07 Ene 2009, 15:48

Hola a todos. Acabo de instalar archlinux con escritorio xfce4. No tengo mucha experiencia en la configuracion de algunos ficheros porque usaba ubuntu/dedian, que configuraba todo automaticamente durante la instalacion. El caso es que quiero cambiar el idioma del escritorio (por defecto ingles). Ya modifique los ficheros /etc/rc.conf y /etc/locale.gen especificando lenguaje espannol y nada.

Tengo que configurar algun otro fichero?? Ayuda por favor.

Muchas gracias de antemano
ediaz
Archer
Archer
 
Mensajes: 20
Registrado: 07 Ene 2009, 14:13

Re: Cambiar idioma a escritorio xfce

Notapor nicros » 07 Ene 2009, 19:00

Podrías postear dichos archivos para estar seguros que no tenga problemas de sintaxis?
Por un foro mas ordenado:
Tema: Problema/Consulta [Solucionado]
Reglas del Foro
Avatar de Usuario
nicros
Equipo Hispano
Equipo Hispano
 
Mensajes: 790
Registrado: 23 Ago 2006, 11:37
Ubicación: Santiago, Chile

Re: Cambiar idioma a escritorio xfce

Notapor ediaz » 08 Ene 2009, 01:34

Gracias nicros por intentar ayudarme. Esto es lo que tengo configurado en rc.conf

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="es_ES.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="Canada/Pacific"
KEYMAP="es"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(e100 eepro100 mii slhc ac97_bus snd-mixer-oss snd-pcm-oss snd-seq-oss snd-seq-device snd-seq-midi-event snd-seq snd-page-alloc snd-pcm snd-rawmidi snd-timer snd snd-mpu401-uart snd-mpu401 snd-ac97-codec snd-intel8x0 soundcore fuse)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="linux-puesto3"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
# - prefix an entry in INTERFACES with a ! to disable it
# - no hyphens in your interface names - Bash doesn't like it
#
# DHCP: Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
eth0="eth0 192.168.0.51 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
# - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

# Enable these network profiles at boot-up. These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
# - set to 'menu' to present a menu during boot-up (dialog package required)
# - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
# - prefix a daemon with a ! to disable it
# - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network netfs crond hal fam alsa esd)


************************************************************************
Y este es el Locale.gen
************************************************************************
## Configuration file for locale-gen
##
## lists of locales that are to be generated by the locale-gen command.
##
## Each line is of the form:
##
## <locale> <charset>
##
## where <locale> is one of the locales given in /usr/share/i18n/locales
## and <charset> is one of the character sets listed in /usr/share/i18n/charmaps
##
## Examples:
## en_US ISO-8859-1
## en_US.UTF-8 UTF-8
## de_DE ISO-8859-1
## de_DE@euro ISO-8859-15
##
## The locale-gen command will generate all the locales,
## placing them in /usr/lib/locale.
##
## A list of supported locales is included in this file.
## Uncomment the ones you need.
##
## This file names the currently supported and somewhat tested locales.
## If you have any additions please file a glibc bug report.
#
es_ES.UTF-8 UTF-8
es_ES ISO-8859-1
es_ES@euro ISO-8859-15
ediaz
Archer
Archer
 
Mensajes: 20
Registrado: 07 Ene 2009, 14:13

Re: Cambiar idioma a escritorio xfce

Notapor nicros » 08 Ene 2009, 02:36

Creo que están bien los archivos, sólo deberías cambiar TIMEZONE (a menos que vivas en Canada)y lo otro es: que manejador de entrada estás usando? gdm, kdm, slim?? cual?
Y por ultimo postea la salida del comando $ locale para ir viendo donde puede estar la falla.

Saludos
Por un foro mas ordenado:
Tema: Problema/Consulta [Solucionado]
Reglas del Foro
Avatar de Usuario
nicros
Equipo Hispano
Equipo Hispano
 
Mensajes: 790
Registrado: 23 Ago 2006, 11:37
Ubicación: Santiago, Chile

Re: Cambiar idioma a escritorio xfce

Notapor pajaro » 08 Ene 2009, 05:52

para cambiar el idioma predeterminado del sistema suelo añadir al final del archivo /etc/profile:

export LANG="es_ES.utf8"

si lo quieres solo para tu usuario, añadelo al archivo ~/bashrc
pajaro
Archer Avanzado
Archer Avanzado
 
Mensajes: 124
Registrado: 26 Sep 2007, 07:01

Re: Cambiar idioma a escritorio xfce

Notapor ediaz » 08 Ene 2009, 17:31

Hola pajaro. Probe agregando export LANG="es_ES.utf8" a /etc/profile y no resulto.

Nicros, esta es la salida de locale:

bash-3.2$ locale
LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE=C
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=


Estoy utilizando gdm.

Tambien probe
ediaz
Archer
Archer
 
Mensajes: 20
Registrado: 07 Ene 2009, 14:13

Re: Cambiar idioma a escritorio xfce

Notapor FedeTheGreat » 08 Ene 2009, 22:59

yo siempre tube xfce4 en español y mi rc.conf era igual al tuyo, salvo que mi zona es Argentina/Buenos_Aires
Me gustan las cosas simples por eso uso Arch!
Linux User# 404818
Nos vemos en irc.freenode.net #archlinux-es
Canal de discusión en Español
Avatar de Usuario
FedeTheGreat
Equipo Hispano
Equipo Hispano
 
Mensajes: 3574
Registrado: 01 Abr 2007, 13:03
Ubicación: Victoria - Buenos Aires - Argentina

Re: Cambiar idioma a escritorio xfce

Notapor pajaro » 09 Ene 2009, 05:33

si no ha habido cambios, el idioma de xfce4 se cambia con

export LANG="loquesea"

prueba a poner es_ES, sin el utf8

prueba a ponerlo en el bashrc
pajaro
Archer Avanzado
Archer Avanzado
 
Mensajes: 124
Registrado: 26 Sep 2007, 07:01

Re: Cambiar idioma a escritorio xfce

Notapor nicros » 09 Ene 2009, 14:05

Bueno creo que el problema va con las "locales", haber, después de editar el archivo locale.gen haz ejecutado locale-gen?? que es lo que genera las locales?
Por un foro mas ordenado:
Tema: Problema/Consulta [Solucionado]
Reglas del Foro
Avatar de Usuario
nicros
Equipo Hispano
Equipo Hispano
 
Mensajes: 790
Registrado: 23 Ago 2006, 11:37
Ubicación: Santiago, Chile

Re: Cambiar idioma a escritorio xfce

Notapor ediaz » 09 Ene 2009, 23:19

Bueno, gracias a todos por intentar ayudar. Ya resolvi el problema. Lo hice reinstalando el sistema y configurando el idioma en el /etc/rc.conf durante la instalacion (cosa que no habia hecho antes, ya que habia dejado el idioma ingles que viene por defecto). No fue la mejor solucion pero resolvi el problema.

Nicros, no habia ejecutado locale-gen. Quisas por eso se mantenia el idioma ingles. Saludos a todos.
ediaz
Archer
Archer
 
Mensajes: 20
Registrado: 07 Ene 2009, 14:13


Volver a Aplicaciones y Entornos de Escritorio

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados