Eñes y acentos en XFCE [SOLUCIONADO]

Todo lo relacionado con los entornos de escritorio, todas las aplicaciones, tanto KDE, Gnome y otros. Si tenes un problema con un programa, muy probablemente este sea el foro indicado.
Avatar de Usuario
Miles
Novato
Mensajes: 10
Registrado: 27 Ago 2008, 07:52
Ubicación: Sevilla (España)

Eñes y acentos en XFCE [SOLUCIONADO]

Mensajepor Miles » 20 Nov 2012, 13:33

Al cambiar de equipo, he instalado de nuevo Archlinux (el arranque ahora con systemd es alucinante) y tengo un problemilla con el idioma en XFCE que en la instalación anterior no tenía.
Cuando inicio el sistema el teclado funciona correctamente, pero al cado de un rato y derrepente dejan de funcionarme los acentos, las eñes y alguna vez el teclado númerico. Para solucionarlo tengo que quitar la configuración por defecto del teclado de XFCE y seleccionar el modelo de teclado y el idioma español en la zona de configuración de teclado de XFCE.
Lo raro es que si salgo de la sesión (incluso guardando ésta) al entrar de nuevo en XFCE se vuelve a reproducir el problema.

He probado a borrar la sesión de XFCE y empezar de nuevo, pero nada.

Llevo varios más de 4 años usando Arch y esto es rarísimo :)

¿Se os ocurre algo que se me haya pasado?

Gracias por anticipado.
Última edición por Miles el 21 Nov 2012, 05:10, editado 1 vez en total.

Avatar de Usuario
Spooky
Equipo Hispano
Equipo Hispano
Mensajes: 1759
Registrado: 19 Nov 2010, 00:33
Ubicación: Behind your computer

Re: Eñes y acentos en XFCE

Mensajepor Spooky » 20 Nov 2012, 14:51

Es simple, dentro de /etc crea un archivo llamado vconsole.conf:

Código: Seleccionar todo

nano /etc/vconsole.conf

En ese archivo debes establecer la variable para el idioma del teclado:

Código: Seleccionar todo

KEYMAP=es


Reinicias tu sistema y ya no deberías tener problemas.
Otra opcion seria mediante pacman instalar el paquete xorg-setxkbmap, luego en tu .xinitrc establecer el idioma del teclado en cada inicio:

Código: Seleccionar todo

setxkbmap es


Saludos

Avatar de Usuario
Jristz
Archer Extremo
Archer Extremo
Mensajes: 744
Registrado: 14 Mar 2011, 21:20
Contactar:

Re: Eñes y acentos en XFCE

Mensajepor Jristz » 20 Nov 2012, 15:11

elige una letra qu te guste y usala
en el etc/X11/xorg.conf.d/10-evdev.conf
deveria ser para mi caso latam

Código: Seleccionar todo

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Option "xkblayout" "latam"
   Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

como lees Option "xkblayout" "latam" setea el teclado a latam, es para español de españa (el con la C con cedilla)
y reinicia las X
deveria de funcionar y autosetearte el teclado al iniciar las X
XFCE 4.10

Avatar de Usuario
Miles
Novato
Mensajes: 10
Registrado: 27 Ago 2008, 07:52
Ubicación: Sevilla (España)

Re: Eñes y acentos en XFCE

Mensajepor Miles » 21 Nov 2012, 05:09

Al final la respuesta de Jristz ha solucionado el problemilla.

Muchas gracias a todos.


Volver a “Aplicaciones y Entornos de Escritorio”

¿Quién está conectado?

Usuarios navegando por este Foro: Google [Bot] y 1 invitado