No conecta a Internet la segunda vez después de la instalación

Para que preguntes sobre cualquier duda que tengas con la configuración de algún componente de hardware, así como placas de sonido, video o grabadoras.
andoni
Novato
Mensajes: 2
Registrado: 09 Ago 2017, 21:17

No conecta a Internet la segunda vez después de la instalación

Mensajepor andoni » 09 Ago 2017, 21:35

¡Hola a todos!

Acabo de instalar Arch Linux en mi portátil Samsung Series 5 por el puro placer de aprender y con la motivación de querer convertirlo en mi sistema operativo principal. En la instalación me ha ido todo bien y ahora me encuentro con unos pequeños problemas. Iré posteándolos poco a poco. El primero de ellos es que después de la instalación (todo correcto al parecer y siguiendo el tutorial de esta página: https://lignux.com/instalemos-arch-linux-paso-a-paso/) no puedo volver a conectarme a internet. Intento utilizar el comando "wifi-menu" pero me dice que tengo que instalar "dialog" para utilizarlo. ¿Cómo puedo hacer para conectarme a Internet una vez instalado y habiendo utilizado wifi-menu"? No estoy diciendo que me conecte automáticamente sino una manera de ver las redes wifi que tengo alrededor y meter la contraseña y punto. Es un ordenador que lo utilizo mucho en bibliotecas y cafés.

¡Muchas gracias!

andoni
Novato
Mensajes: 2
Registrado: 09 Ago 2017, 21:17

Re: No conecta a Internet la segunda vez después de la instalación

Mensajepor andoni » 10 Ago 2017, 10:59

Lo que he hecho es:

1.- Volver a meter el USB para bootear como si fuera a instalarlo de nuevo y arrancar el sistema desde el USB
2.- Conectarme a internet a través de "wifi-menu"
3.- Archroot
3.- Descargar e instalar "dialog" para usar "wifi-menu" en el sistema

Ahora el problema es que cuando reinicio y entro a wifi-menu (todo correcto) y elijo la red a la que me quiero conectar, sin que me deje meter la contraseña me pone lo siguiente:
Job for [email protected]\x2ddde438.service failed becuase the service did not take the steps required by its unit configuration. See "systemctl status "[email protected]\\x2ddde438.service"" and "journalctl -xe" for details.

¿Alguno sabe como arreglarlo?

Gracias de antemano

Avatar de Usuario
nicros
Equipo Hispano
Equipo Hispano
Mensajes: 814
Registrado: 23 Ago 2006, 10:37
Ubicación: Santiago, Chile

Re: No conecta a Internet la segunda vez después de la instalación

Mensajepor nicros » 06 Sep 2017, 13:32

Efectivamente, es necesario instalar dialog para ser utilizado con wifi-menu.
Me parece que otra dependencia es wpa_supplicant (deberías hacer el mismo proceso que con dialog para instalarlo)
Y por ultimo, te recomendaría instalar otro gestor de redes como wicd o NetworkManager https://wiki.archlinux.org/index.php/NetworkManager
Por un foro mas ordenado:
Tema: Problema/Consulta [Solucionado]
Reglas del Foro

Avatar de Usuario
atb
Archer
Archer
Mensajes: 29
Registrado: 22 Nov 2016, 10:52

Re: No conecta a Internet la segunda vez después de la instalación

Mensajepor atb » 08 Sep 2017, 06:03

Hola Andoni,
No puedo resistir la tentación de aportar mi "granito", porque tuve el mismo problema, pero te anticipo que tengo muy pocos conocimientos sobre el tema.
Yo lo solucioné como te sugiere Nicro, gestionando mi conexión con NetworkManager.
Partimos de la base que ya lo habías instalado así:

Código: Seleccionar todo

# pacstrap /mnt networkmanager

Harías lo siguiente:

Código: Seleccionar todo

# systemctl start NetworkManager.service
# systemctl enable NetworkManager.service
# reboot
$ sudo nmcli dev wifi connect nombre_red password tu_password
$ ping -c 5 www.google.co.uk

Espero te ayude,
Un atento saludo: Alberto
"Las cosas que nosotros compartimos en nuestro mundo son mucho más valiosas que las que nos dividen."
- Donald Williams, EUA


Volver a “Hardware - Consultas, Configuración y Problemas”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado